Planting - EXCEPTION TYPE::ACCESS VIOLATION

Share your designing tips with other Designer's. Find answers to your problems using the APCD.
Post Reply
Ian Wells
Posts: 579
Joined: August 27th, 2019, 3:02 am

Planting - EXCEPTION TYPE::ACCESS VIOLATION

Post by Ian Wells »

I was starting to do the plant the grass on Gozzer Ranch using the Plant Forest.
For an unknown reason the Plant Forest sometimes worked and sometimes not, approx 1 in 5 worked. In light of the posts regarding blank areas of planting, I was planting small areas and checking each time and then saving after each hole was planted. If the planting did not occur I used the "Undo Forest". This was tedious and very time consuming. As I started the fourth hole I had a "EXCEPTION TYPE::ACCESS VIOLATION" announcement. As I had just saved I was not so angry, and restarted the planting. This time the Plant Forest worked every time.

Does anybody have any idea why the Plant Forest worked intermittently? I assume the "EXCEPTION TYPE::ACCESS VIOLATION" which required a new start to APCD, cleared whatever was causing the problem?

For once, and probably the only time, I can say I was happy to receive the violation. :smile:

Ian
Colin Jones
Posts: 72
Joined: January 29th, 2021, 5:59 pm
Location: Gold Coast, Australia

Re: Planting - EXCEPTION TYPE::ACCESS VIOLATION

Post by Colin Jones »

Hey Ian, trust you're well mate (if a little frustrated)

My experience is that it occurs when you are planting high-density small plants (the size of the area being planted doesn't seem to be a factor)

I've had success, following an unsuccessful forest plant, by just planting the required object as a single. This seems to (sometimes) "unlock" the plant and then you can resume forest planting it. I've also has success by changing the density and the object min/max size settings.

Other than that, its unpredictable. I don't know why this has only started to be an issue in my later courses.......

For the record, here's the simple fix if you happen to miss an undo and get blank patches:
- Make sure the entire course is visible in Top View (or similar)
- Go to your Plantings tab and select 2D
- From the menubar, click on Select then All
- Deselect your visible objects by holding down the Control key, and then box-selecting your entire plot in Top View (at least covering all the areas that have been planted)
- It can take some time (a few minutes perhaps) to deselect everything if you have alot of objects planted, so just be patient..............

- When you are sure it has finished deselecting, hit the X (delete) button.

The "hidden 2D objects" will now be deleted. The course should be fine and fully plantable again.
Completed: Golf Club of Houston (Redstone); Banff Springs; Mauna Kea 2024
Working on: Royal Sydney (2024); NSW Golf Club (2024)
Ian Wells
Posts: 579
Joined: August 27th, 2019, 3:02 am

Re: Planting - EXCEPTION TYPE::ACCESS VIOLATION

Post by Ian Wells »

Colin,
I am well, thank you. (The frustration eased as the amber nectar disappeared from the fridge. :ill: :smile: )

Prior to the problem with the intermittent foresting I had the problem with blank areas of planting. After that I followed the instructions you posted:
The fix:
There are hidden 2D objects in your CRZ that must be removed, To do so:
- Make sure the entire course is visible in Top View (or similar)
- Go to your Plantings tab and select 2D
- From the menubar, click on Select then All
- Deselect your visible objects by holding down the Control key, and then box-selecting your entire plot in Top View (at least covering all the areas that have been planted)
- Whilst it may appear that there are no longer any 2D objects selected, hit the X (delete) button.

The "hidden 2D objects" will now be deleted. The course should be fine and fully plantable again.
Since then, the planting has been fine - at least for the first 4 holes. :whistle: :fcrossed:

Thank you. :tiphat:
Ian
Post Reply