Running Links 2003 on an M1 iMac???

Having hardware or software problems related to Links? Other forum members may be able to help you here.
Post Reply
Swandy
Posts: 2
Joined: Mon Aug 23, 2021 7:46 pm

Running Links 2003 on an M1 iMac???

Post by Swandy »

I purchased one of Apple's M1 iMacs earlier this year. Also running Windows 11 for ARM under Parallels. But I cannot seem to get Links 2003 (have the original disk versions' files burned to a CDR and also purchased the download version from the Links Country Club website (in case that would be easier to install) but neither works. I either get various errors (usually a missing DLL file) or the game will "start", run in a small windows and anytime I try to change the resolution it fails and quits.
Now - granted I am running a M1 iMac which is Apple's new Apple Silicone which is obviously based on an ARM processor (hence the Windows 11 ARM version being necessary) which might be causing issues (DUH).
Anyone successful at getting Links 2003 to run? And HOW did you do it?
Thanks.
Davefevs
Posts: 4
Joined: Tue Nov 22, 2022 9:07 pm

Re: Running Links 2003 on an M1 iMac???

Post by Davefevs »

I’ve just loaded up parallels on my MacBook, installed Links2003, and fired it up. It ends up rendering too big for my screen, so I can’t see all the menus. Esc and Enter got me back to my windows desktop.

I then right clicked on the app, then properties, then compatibility tab, then change high dpi settings and ticked both boxes.

I then relaunched the game and it rendered on my screen properly.

But then I hit all kinds of display issues, such as no swing meter, choppy swing meter, can’t see snap point, etc.
Ian Wells
Posts: 391
Joined: Tue Aug 27, 2019 2:02 am

Re: Running Links 2003 on an M1 iMac???

Post by Ian Wells »

In November of 2021, I partitioned my daughters iMac using Bootcamp and was happily surprised how easy it went. I downloaded Windows 10 and the Links2003 download from LSPN. The only problem I had was I had to use DGVOODOO to get the graphics working correctly. (The exact reason I had to use this I have forgotten.)

This year when I opened the iMac, I updated the IOS to the latest version and I also selected that the system opens in Windows on startup, in place of using the Option key.
Since then, I have been unable to access the Apple side of the computer. I asked for help on the Apple site but there was no solution forthcoming. My Links2003 now runs at a frame rate of 10-12 which makes it unplayable, in my opinion. I had a suggestion from Chad to update the drivers, but I believe I have to be on the Apple IOS to do that.

In place of an Apple iMac with Windows for playing Links, we now have No Apple computer and an unusable Windows for Links. :rant: :rant:

If you get your system working with Windows, my advice would be to be very wary about updating the system.

Good luck.
Ian
Davefevs
Posts: 4
Joined: Tue Nov 22, 2022 9:07 pm

Re: Running Links 2003 on an M1 iMac???

Post by Davefevs »

I’ve just been reading through the various posts on the DGV graphics stuff, downloaded it, added to links folder, and I now have what appears to be a decent working version of Links 2003 mod 1.07 on my Mac through Parallels. 🙂🙂🙂

Need to d/l some of the old courses I used to play.

(MacBook Pro 2019)
Davefevs
Posts: 4
Joined: Tue Nov 22, 2022 9:07 pm

Re: Running Links 2003 on an M1 iMac???

Post by Davefevs »

For info, I loaded the Nvidea patch and that started giving me 8/9 fps, so I reinstalled Links, added 1.07 and then the DGV update to force it to think I have a graphics card, and I’m back up to 25-30 fps.
Post Reply