
LIDAR Tutorial 1 – Creating Green Contours in QGIS 

This tutorial will describe the necessary steps and concepts needed to create green contour maps in QGIS. It 
cannot describe how to fully use all the programs mentioned in this tutorial, there are better resources for 
that than me. There are usually multiple ways to achieve the same results in QGIS so the steps I describe may 
not be the only way. 

The applications of the tutorial go beyond golf course design in the APCD. You could create green contour 
maps for your local golf course, maps for a course you will play on vacation, or maps for a tournament course 
you will be watching on tv. The accuracy of the green contour maps produced here are high quality provided 
that the LIDAR data is up to date. 

The programs needed for this are QGIS, Google Earth Pro, and a basic bitmap image program. All are available 
as free downloads. 

Find the golf course in Google Earth and corresponding LIDAR data 

The first step in this process is likely the hardest to describe. Most popular golf courses will come up with a 
search right in Google Earth. You could try searching for a town near the golf course and then panning around 
in Google Earth to find the golf course area. Once the course is found it may be helpful to write the LAT and 
LONG coordinates on a scrap piece of paper. 

 

 

  



The are countless sources for LIDAR elevation data and it is not possible to describe how to use all the 
websites. Each country, state, province, municipality, town, etc. may offer free downloads of LIDAR elevation 
data. The file format we are looking for in this tutorial are geoTIFF files with the extension .tif. LIDAR data may 
come in the original point cloud form (.las or .laz) but we will be using the published form of the data as raster 
images. I should note that there may be other raster image formats other than .tif files that have elevation 
data. 

Sidenote - To complicate things further there are different types of LIDAR data regarding how vegetation is 
handled. All LIDAR survey returns would include the elevations from the trees, scrubs, buildings, etc. This 
would generate a digital surface model DSM. The point clouds from the LIDAR survey can be post-processed to 
filter out the elevations from vegetation and lower ground elevations. The elevations only from the ground 
points produce a digital terrain model DTM. DTM’s can include some post-processing to fill holes in the LIDAR 
survey and verification against other elevation data products. We want to work with DTM data products when 
using LIDAR for golf courses. Double, even triple check that the LIDAR data you get is a DTM! 

 

  



I will generate green contours for the 18th hole at Chambers Bay for this tutorial. Finding the course in Google 
Earth shows the coordinates as roughly 47.20 LAT and -122.57 LON. Open the historical imagery tab in Google 
Earth and try to find the best overlay image that seems the most accurate. Also take into consideration when 
the LIDAR data survey was completed. For this course, I am choosing the 2020-8-14 satellite image. 

A useful website for finding LIDAR data in the US is the United States Interagency Elevation Inventory. This 
website pools LIDAR data sources together from multiple sources and shows when in-progress LIDAR surveys 
may become available. At the homepage, type in the LAT and LON coordinates for our target area. This brings 
up multiple sources of LIDAR data from 2002 to 2020. Under the data access header, you will find a link to The 
National Map. Most of the US LIDAR data is provided by this USGS website. 

 

 

 

At The National Map (TNM) website, search for the coordinates of our target area again. From the data 
sources tab, click Elevation Products (3DEP), click 1m DEM, and for file formats click all. You can also click the 
Show Availability button to highlight areas of the map with data coverage our selected criteria. Finally, go back 
near the top and click Search Products. This will bring up a link to the 2020 geotiff file we are looking for. 



 

 

 

  



Sidenote - There are 2 basic forms of GIS data; vector data and raster data. Vector data is described as vertex 
coordinates and comes in the form of points, lines, and polygons. Points are a single vertex coordinate, lines 
are several vertices considered connected together, and polygons are areas represented by a boundary line of 
vertices. Raster data comes in the form of georeferenced pixel images. The background images in Google 
Earth are raster images that are referenced to the specific area they cover on the ground. Each pixel in these 
images contain RGB color information. GeoTIFF files of LIDAR elevations are similar but contain a floating-
point value for the ground elevation covered by the pixel, not color information. 

Draw a polygon around the green in Google Earth. 

Google Earth image overlays have some location error present in the positioning. It is hard to describe how to 
gauge this but try to work with the highest quality image available, even if it means going back a few years 
with the historical image tab. I try to pick an overlay image with the best clarity (high resolution) and low 
shadows.  

Make a new folder in the My Places tab. Use the polygon creation tool and draw around the perimeter of the 
green. Each click adds a vertex to the polygon so try to have enough vertices to make a smooth, rounded 
shape to define the green edge. 

 

If you plan to do all the greens for the course draw an individual polygon for each green and label it in the 
folder accordingly. When complete the next step is to export the polygons to a .kml file. Don’t export as a zip 
compressed file .kmz. I recommend the folder contains only polygons of green shapes. It is possible to mix 
points, lines, and polygon geometries in a My Places folder and export all to a .kml file. The QGIS file importer 
will show the data types available but only 1 geometry type can be imported to a layer. 

  



Start QGIS and add the LIDAR and Google Earth data to a project. 

The start screen for QGIS shows the recent project files and program updates available. You need to start a 
new project. This can be done by going to the top menu and Project > New or clicking the New Project button 
on the top ribbon. There are a few housekeeping items to make the screen look like mine. Go to View -> 
Panels and turn on the Layers, Processing Toolbox, and Identify Results windows. Also go to View -> Toolbars 
and select those that I have turned on. The Contour plugin will need to be activated and downloaded. Go to 
Plugins -> Manage and Install Plugins, search for the Contour Plugin, click the check box beside it, and click 
install plugin. 

 

Sidenote – It is time to have the talk about GIS coordinate systems. I am not an expert but you have to have a 
rough understanding of coordinate systems to use GIS software. There are 2 main types of coordinate systems 
used in GIS programs. The first is raw coordinates of LAT and LONG measured in angular units. This system 
utilizes a datum to describe the spherical shape of the earth and angle degrees for a location on the earth 
surface. As survey precision has improved over the years, there have been different ways of describing the 
mean sea level of the earth. The earth is not a perfect round sphere, it is an spheroid that bulges at the 
equator and is somewhat squashed at the poles. There are numerous ways to describe this shape but the 
most recent and common seem to be NAD83 and WGS84. The second coordinate system type in GIS is a 
projected coordinate system. The units of these systems are linear for a flat surface and commonly in meters. 
These systems take a small section of the earth surface and project it as a flat surface. The most common is 
the UTM coordinate system but there are numerous available. The UTM system takes 6 degrees of longitude 
and considers it a nearly flat surface. LAT and LON coordinates are then projected onto a flat surface to get 
linear coordinates. The full UTM coordinate system is describe as a datum and a zone. For Chambers Bay the 
UTM coordinates are zone 10N. Google Earth .kml files use the WGS84 datum and raw LAT and LON 
coordinates. LIDAR data is commonly found using a flat projected coordinate system with linear Eastings (X) 
and Northings (Y) coordinates in meters. QGIS will handle conversions back and forth between thousands of 
different coordinate system combinations but it is essential to understand the differences and why it is 
necessary to convert between the systems.  



I recommend adding the LIDAR data first in QGIS and setting the project coordinate system to this coordinate 
system. You can use the internal file explorer in QGIS left side panel to add layers to the project or go Layer -> 
Add Layer or even drag and drop the files in the main screen. You may get a coordinate system warning 
message. I recommend clicking cancel for this message, but only for this time. Go to the project layers screen 
on the left side and right click on the LIDAR data file, go to Layer CRS and then click on “Set project CRS from 
Layer”. This will set the project coordinate system to the native coordinate system of the LIDAR data. It is 
possible to change the coordinate system of the LIDAR data but I don’t recommend it. This will usually 
introduce a slight rotation and scaling of the pixel image and the edges of the pixels won’t correspond to even 
values of meters. This is important for how we are going to use the LIDAR data. 

 

 

 

Check the coordinate system properties in the project file. Go to Project -> Properties to bring up the 
properties screen. Double, even triple check that the project CRS is the same as the LIDAR data CRS. 



 

 

With the LIDAR data imported and project coordinate system set up, the next step is to add the Google Earth 
.kml file. Go to the menu item Vector -> Data Management Tools -> Reproject Layer. This brings up a window 
of options. Select the .kml file, set the coordinate system to Project CRS: ESPG:26910 – NAD83 / UTM Zone 
10N.   

You can drag and drop the .kml file into the project map window and select the transform settings for the CRS 
shift. This will make the layer visible but I don’t think it will be editable within QGIS. It depends on what you 
plan to do with the layers data in the project. For viewing, just drag and drop them in the project map window. 
For editing, it is best to convert the layer into a .shp file of the same project CRS. 



 

You will notice that QGIS added a temporary file to the Layers window called Reprojected. At the end of the 
layer name, you will see a computer processor type symbol; this means the layer is only temporary and will be 
discarded if not saved when exiting QGIS. Right click on the layer name to bring up the layer’s options menu. 
Get used to doing this because a lot of the work we will be doing with layers can start from this menu. 

 



For vector layer files you will be using repeatedly and editing, I recommend saving them as a .shp file. Right 
click the layer name, go to Make Permanent. Save as an ESRI Shapefile file in the same directory. Then add the 
.shp file to the project and remove the temporary scratch layer. Zoom into the 18th green by right clicking on 
the project layer and then Zoom to Layer(s). 

The map screen will shift to an ugly colored polygon that is our green shape. Right click the layer name and go 
to Properties. 

 

There is lots of useful stuff in just the first few tabs on the left side of the window. I frequently check the 
Information and Source tab for information on the layers within the project. The symbology and labels tabs 
contain a whole multitude of options on how to view your data in the map window. For now, I will change the 
view of the polygon to a green outline that is 2 pixels wide. You can click apply to view the symbology changes 
before exiting the window with clicking Ok. 

The LIDAR data view is likely a blob of similar colored pixels. We can change that. Click on the identify button 
near the top of the screen. Then go to the map screen and click inside the green polygon. It will ask which 
layer to identify, click the raster layer name. In the identify window at the right side you can see the elevation 
value of the raster pixel you clicked on. For the 18th green at Chambers Bay, the elevation is about 15 meters 
above sea level.  



 

To improve the viewability of the LIDAR data in this small area, right click the layer name and go to properties, 
then the symbology tab. Change the min and max values of the black to white color gradient to 12 and 18. 
Now, elevations less than 12 appear all black and over 18 appear all white. You can navigate and zoom in 
around the LIDAR data. If you zoom in close enough you will see the edges of the pixels correspond to even 
values of meters in the projected UTM 10N coordinate system.  

 



Create a point grid to sample the LIDAR data 

In the QGIS top menu go to Vector -> Research Tools -> Create Grid. The key to this process is the extent of the 
grid. Click on the dotted button after the grid extent line and select draw on canvas. Pick a box area large 
enough to cover the green and surrounding areas. Now, the 4 extent values that come up will be some 
decimal number of the grid coordinates. We want to sample the square raster pixels in the center. The grid 
calculator starts at the top left of the extent box. As described in the right-side description, the grid starts at 
the minimum X coordinate and maximum Y coordinate. To sample the center of the LIDAR pixels, manual 
change the extent values to end whole meter values. The LIDAR pixels are 1m in size so the grid spacing is 1m 
vertical and horizontal. 

 

Now move the grid 0.5m in the X and Y direction to the center of the LIDAR pixels. To do this, type translate in 
the processing toolbox search box and under vector geometry click on the translate function that comes up. 
Select the grid we created as the input layer and type in 0.5 for the X and Y values for offset distance. Zoom in 
close to the pixels to notice that the new grid is now centered in the pixels. 



 

Sample the raster values with the point grid 

In the processing toolbox type sample to bring up the sample raster values function under the group raster 
analysis. Select the grid layer called Translated for the input layer and select our raster layer in the project.  

 



Use the contour plugin to create contour lines 

Under the top menu bar go to Vector -> Contour to bring up the options screen. The point layer we want is 
called Sampled, under the data value to use select the SAMPLE_1 table header and in the interval box type in 
0.05 for the contour interval. For this tutorial we are going to create 0.05 m contour lines (5cm or roughly 2 
inches). This value can be changed to meet your needs. The rest of the options should be fine as is and not 
require changing. Click Add to create the contour lines and Close to finish. 

 

 

 

Change the map view to meet your needs 

Zoom out and you will find that the map view is a convoluted mess of points and contour lines. To turn off the 
grid points, click on the check mark next to the layer name to turn off the layer from view. Also turn off the 
raster layer view.  



 

 

That’s it! We have successfully created 5cm (2 inch) green contours for the 18th green at Chambers Bay! To 
create a bitmap image of the map view, go to the top menu and Project -> Import / Export -> Export Map as 
Image. Lots of options here but the one to change to meet your size requirement is the Resolution value. 
Change this to increase or decrease the output dimensions of the bitmap image. I don’t recommend changing 
the scale here, the image will look different than what is currently in the map view. The boxes for draw 
decorations, draw annotations, and append georeferenced information can be un-checked for exporting a 
simple image.  

  



Optional steps for adding detail to green contour maps 

Adding labels to contour lines 

There are lots of other things we can do in QGIS to improve the view or add information to it. Right click on 
the contour lines layer, bring up the Labels tab. At the top, change the No Labels button to Single Labels. 
Change the label value selector to label. This table value in the contour line shapefile was generated in the 
contour plugin.  

There are lots of label viewing options! I like setting the font size to pixels, usually 10 or 12 since most of my 
exports are bitmaps. You can add a small buffer of white pixels around the font if needed. The other settings I 
commonly use are the label placement. For contour lines I like the parallel mode. For other lines the horizontal 
mode may be better. I like to set a repeat of the line label to about 20 meters at scale. You also may want to 
change the priority of the display of labels and uncheck the features act as obstacles option.  

 

 

  



Label the grid points of the sampled data 

Try adding labels to the point grid data to show the background elevations on the green. Bring up the layers 
properties window, turn on single labels, and then check the expression button at the far right of the labels 
value tab. Type “round(“ to start the round math function, select "SAMPLE_1" from the fields and values list, 
and then type “,2)” to finish the round function specifying 2 decimal places for labels. All other label options 
are similar. In placement mode, select Offset from Point, and select the central position. Go to the Symbology 
Tab and turn off the point symbol by selecting Transparent Fill Colour and No Pen for the outline. This may be 
very useful when using the green contour map as a texture in the APCD.  

 

 

  



Add a centroid to the green polygon to find the center of the green 

Tired of using the move hole path and the tape measure in the APCD to estimate the center of the green? 
Take the guess work out of it by finding the green centroid. Go to the top menu and Vector -> Geometry Tools 
-> Centroids and select the greens layer. When finished go into the layers property and the symbology tab to 
change the looks of the centroid. I like the green center to be large and distinct so it shows up easily in the 
APCD when laying out the hole path.  

 

 

  



Add buffer rings to the green polygon to layout an even seam blend for the fringe 

Frustrated when moving verts to get an even width fringe to encircle the green in the APCD? Go to the top 
menu and Vector -> Geoprocessing Tools -> Buffer. Word of advice before you start; this tool will only buffer 
to the outside of polygons but will buffer both sides of a line. If your green seam blend goes to the fairway 
without a fringe ring, then create a buffer around the green polygon. If you want that even fringe ring around 
the green, go to the top menu and Vector -> Geometry Tools -> Polygons to Lines. Then buffer the line to get 
both sides of the seam blends necessary to create that even fringe ring. For this tutorial I converted the green 
polygon to a line, then for the buffer tool I selected a distance of 1.0 m and 1 segment to create a 1-meter 
fringe ring around the green after seam blended. A shortcut to applying layer styles to new layers of the same 
geometry is to right click on the layer, go to Styles -> Copy Styles -> All Categories. Copy the style of the 
original green boundary to the new seam blend locations. 

 

 

  



Add a slope raster image to the background 

This is a favorite of mine. It is not as detailed as the slope maps from Strakaline or Puttview but is very useful 
when placing pin positions. Go to the top menu and Raster -> Analysis -> Slope. Use our LIDAR elevations 
raster as the input layer, click Slope expressed as percent instead of degrees, and double check that it is 1.00 
for the ratio of vertical units to horizontal. The result will be a raster layer that is mostly black to the view. 
Right click the layer name, go to properties, and then the symbology page. Change the render type to 
Singleband Psuedocolor, change the min and max values to about 0 and 10, create 5 label classes using the + 
and – buttons, select the colors for each label class, check that mode is continuous, and finally change the 
resampling to cubic to smooth the color gradient between the 1-meter pixels. The result will produce a green 
slope map with contour intervals that is almost as good as you could purchase. 

 

 

  



To export a high-resolution image of the map screen, go to top menu and Project -> Import/Export -> Export 
map to image. Any output images for the APCD will need to be cropped and maybe resized to a square power 
of 2 sized (512x512, 1024x1024, 2048x2048, 4096x4096) .tga image for use as an APCD texture. 

 

 

 

That’s it for this tutorial. I’ve shared all the ideas I have to make green contour maps for personal use or for in 
the APCD. I’m sure there are many more ideas out there and useful tools to make green contour maps in 
QGIS! 


